<!DOCTYPE html>
<html lang="en" class="">
<head prefix="og: http://ogp.me/ns# article: http://ogp.me/ns/article# video: http://ogp.me/ns/video#">
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width, initial-scale=1.0">
	<meta http-equiv="X-UA-Compatible" content="IE=edge" />

	<!-- Metadata -->
	<title>The first DDoS attack was 20 years ago. This is what we’ve learned since. - MIT Technology Review</title>
	<link rel="shortcut icon" href="/favicon.ico?v=2" type="image/x-icon">
	<meta name="description" content="On the 20th anniversary of the first distributed denial of service attack, cybersecurity experts say the internet must be redesigned to prevent them.">

	<meta name="author" content="Emerging Technology from the arXiv"/>

	<meta name="standout" content="https://www.technologyreview.com/s/613331/the-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since/"/>

	<!-- Open Graph -->
	<meta property="og:url" content="https://www.technologyreview.com/s/613331/the-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since/"><meta property="og:title" content="The first DDoS attack was 20 years ago. This is what we’ve learned since."><meta property="og:type" content="article"><meta property="og:updated_time" content="2019-04-18T09:46:45-04:00"><meta property="og:image" content="https://cdn.technologyreview.com/i/images/arxivddos2.jpg?cx=0&cy=0&cw=3000&ch=1687&sw=1200">
	<meta property="og:image:url" content="https://cdn.technologyreview.com/i/images/arxivddos2.jpg?cx=0&cy=0&cw=3000&ch=1687&sw=1200">
	<meta property="og:image:type" content="image/jpeg">
	<meta property="og:image:width" content="3000">
	<meta property="og:image:height" content="1688">
	<meta property="og:description" content="On the 20th anniversary of the first distributed denial of service attack, cybersecurity experts say the internet must be redesigned to prevent them."><meta property="og:site_name" content="MIT Technology Review">

	<!-- Twitter -->
	
		<meta name="twitter:card" content="summary_large_image">
		
		<meta name="twitter:site" content="@techreview">
		
		<meta name="twitter:description" content="On the 20th anniversary of the first distributed denial of service attack, cybersecurity experts say the internet must be redesigned to prevent them.">
		
		<meta name="twitter:title" content="The first DDoS attack was 20 years ago. This is what we’ve learned since.">
		
		<meta name="twitter:image" content="https://www.technologyreview.com/i/images/arxivddos2.jpg?sw=560&cx=0&cy=0&cw=3000&ch=1687">
		

	<!-- Schema.org -->
	<script type="application/ld+json" id="NewsArticle">{"@context":"http://schema.org","@type":"NewsArticle","headline":"The first DDoS attack was 20 years ago. This is what we’ve learned since.","description":"On the 20th anniversary of the first distributed denial of service attack, cybersecurity experts say the internet must be redesigned to prevent them.","url":"https://www.technologyreview.com/s/613331/the-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since/","dateCreated":"2019-04-18T09:00:00-04:00","datePublished":"2019-04-18T09:00:00-04:00","dateModified":"2019-04-18T09:46:45-04:00","mainEntityOfPage":{"@type":"WebPage","@id":"/s/613331/the-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since/"},"creator":"Emerging Technology from the arXiv","author":{"@type":"Person","name":"Emerging Technology from the arXiv"},"publisher":{"@type":"Organization","name":"MIT Technology Review","logo":{"@type":"ImageObject","url":"https://cdn.technologyreview.com/_/img/stacked-logo-v2.svg","width":184,"height":90}},"thumbnailUrl":"https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=3000","image":{"@type":"ImageObject","url":"https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=3000","height":3000,"width":1688},"articleSection":"Connectivity"}</script><script type="application/ld+json" id="Organization">{"@context":"schema.org","@type":"Organization","name":"MIT Technology Review","address":{"@type":"PostalAddress","addressLocality":"Cambridge, MA, USA","postalCode":"02142","streetAddress":"1 Main Street"}}</script><script type="application/ld+json" id="searchBox">{"@context":"http://schema.org","@type":"WebSite","url":"https://www.technologyreview.com","potentialAction":{"@type":"SearchAction","target":"https://www.technologyreview.com/search/?s={s}","query-input":"required name=s"}}</script><script type="application/ld+json" id="searchBreadcrumbs">{"@context":"http://schema.org","@type":"WebSite","name":"MIT Technology Review","alternateName":"Technologyreview.com","url":"https://www.technologyreview.com"}</script>

	
	<link rel="canonical" href="https://www.technologyreview.com/s/613331/the-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since/">
	

	
	<link rel="amphtml" href="https://www.technologyreview.com/s/613331/the-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since/amp/">
	

	

	<!-- Google Sign-in -->
	<meta name="google-signin-client_id" content="420520515534.apps.googleusercontent.com">

	<!-- Facebook Instant Articles -->
	<meta property="fb:pages" content="17043549797" />

	<!-- Bing -->
	<meta name="msvalidate.01" content="5294BBA10FC9AF4ACAA562681389518D" />

	
<link rel="stylesheet" href="https://cdn.technologyreview.com/_/dist/css/article.css?v=bf2fbea2">


	<!-- Stylesheets -->
	

	<!--[if lt IE 9]>
	<script src="//cdnjs.cloudflare.com/ajax/libs/es5-shim/4.0.5/es5-shim.min.js"></script>
	<script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.2/html5shiv.min.js"></script>
	<![endif]-->

	<!-- Google Tag Manager Data Layer-->
	
	<script>
	dataLayer = [{"Contributor":"Emerging Technology from the arXiv","PageType":"News","Pubdate":"2019-04-18","WordCount":"01200","DelayPageview":"true","EntryID":613331,"Topic":"Connectivity","ABTestVariant":"topper"}];
	</script>
	

	
	<!-- Google Tag Manager -->
	<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
	new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
	j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
	'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
	})(window,document,'script','dataLayer','GTM-TRBQMN');</script>
	<!-- More GTM-related stuff (for Optimize) -->
	
	
	
	

	
	</head>
<body class=""
	data-model="master"
	rv-class-js-mobile-nav-is-open="mobileNav.open"
	rv-class-js-mobile-nav-is-fixed="mobileNav.fixed"
	rv-class-js-nav-is-open="nav.open"
	rv-class-js-nav-is-fixed="nav.fixed"
	rv-class-js-search-is-open="search.open"

	
	>


<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TRBQMN" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>



	
		
<div id="fullpage-interstitial-overlay">
	<div id="fullpage-interstitial-container">
		<div id="subscriber-roadblock" class="adunit"
			data-adunit="__subscriber/__roadblock"
			data-size-mapping="subscriber-roadblock"
			data-active="false">
		</div>
	</div>
</div>

	

	
	<section class="incognito-wall">
	<div class="incognito-wall__wrapper">
		<a href="/"><img class="incognito-wall__logo" src="https://cdn.technologyreview.com/_/img/stacked-logo-v2.svg" alt="MIT Technology Review"></a>
		<div class="incognito-wall__intro">
			<p>Hello,</p>
			<p>We noticed you're browsing in private or incognito mode.</p>
		</div>
		<div class="incognito-wall__body">
			<p>To continue reading this article, please exit incognito mode
				or <a href="/login/?redirectTo=%2Fs%2F613331%2Fthe-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since%2F">log in</a>.</p>
			<p>Not a subscriber? Subscribe now for unlimited access to online articles.</p>
			<a href="https://go.technologyreview.com/insider/pricing/" class="btn btn--primary--transparent incognito-wall__subscribe-btn">
				<span class="txt">Subscribe today</span>
				<span class="btn--primary--transparent__icon">
<svg class="btn__icon--angle-arrow" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 10.1 10.1" enable-background="new 0 0 10.1 10.1" xml:space="preserve">
	<polygon fill="#FFFFFF" points="0.9,0 0.9,2.5 5.9,2.5 0,8.4 1.8,10.1 7.6,4.3 7.6,9.2 10.1,9.2 10.1,0 "/>
</svg>
</span>
			</a>
		</div>
		<div class="incognito-wall__footer">
			<h4>Why we made this change</h4>
			<p>Visitors are allowed 3 free articles per month (without a subscription), and private browsing prevents us from counting how many stories you've read. We hope you understand, and consider <a href="https://go.technologyreview.com/insider/pricing/">subscribing</a> for unlimited online access.</p>
			<div><a href="/">Back to MIT Technology Review home</a></div>
			<div><a href="/help/contact/">Contact customer service</a> if you are seeing this message in error.</div>
		</div>
	</div>
</section>

	

	

	
		<!-- Site Header / Nav -->
		
	

<header id="header" role="banner">
	<nav class="navbar">
		<div class="navbar__width">
			<a class="navbar__logo-mod" href="/">
				<img class="navbar__logo" src="https://cdn.technologyreview.com/_/img/stacked-logo-v2.svg" alt="MIT Technology Review">
			</a><!-- header-logo -->

			
				<button class="navbar__mobile-menu" data-mobile-menu="toggle">Menu</button>
			

			
			

			<div class="navbar__navigation">
				<ul class="navbar--primary">

					

					<li class="navbar__item--primary navbar__item--expandable navbar__item--primary--topics">
						<span class="navbar__item__link navbar__item__link--primary navbar__item__link--expandable">Topics<span class="navbar__item__link--expandable__plus"></span></span>
						<ul class="navbar__dropdown">
							<li class="navbar__topics__section-container">
								<ul class="navbar__topics__section--topics">
									<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="/topic/business-impact/">Business Impact</a></li>
									<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="/topic/connectivity/">Connectivity</a></li>
									<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="/topic/intelligent-machines/">Intelligent Machines</a></li>
									<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="/topic/rewriting-life/">Rewriting Life</a></li>
									<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="/topic/sustainable-energy/">Sustainable Energy</a></li>
								</ul>
							</li>
							<li class="navbar__topics__section-container">
								<ul class="navbar__topics__section--lists">
									<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="/lists/technologies/">10 Breakthrough Technologies</a></li>
									<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="/lists/innovators-under-35/">35 Innovators Under 35</a></li>
									<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="/lists/companies/">50 Smartest Companies</a></li>
								</ul>
							</li>
							<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="/views/">Views</a></li>
							<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="/views-from-the-marketplace/">Views from the Marketplace</a></li>
						</ul>
					</li>

					<li class="navbar__item--primary"><a class="navbar__item__link navbar__item__link--primary" href="/the-download/">The Download</a></li>
					<li class="navbar__item--primary"><a class="navbar__item__link navbar__item__link--primary" href="/magazine/">Magazine</a></li>
					<li class="navbar__item--primary"><a class="navbar__item__link navbar__item__link--primary" href="https://events.technologyreview.com/">Events</a></li>

					<li class="navbar__item--primary navbar__item--expandable navbar__item--primary--more">
						<span class="navbar__item__link navbar__item__link--primary navbar__item__link--expandable">More<span class="navbar__item__link--expandable__plus"></span></span>
						<ul class="navbar__dropdown">
							<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="/videos/">Video</a></li>
							<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="/business-lab/">Podcasts</a></li>
							<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="/magazine/special-publications/">Special Publications</a></li>
							<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="/mit-news/">MIT News magazine</a></li>
							<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="https://go.technologyreview.com/newsletters">Newsletters</a></li>
							<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="/help/">Help/Support</a></li>
							<li class="navbar__dropdown__item"><a class="navbar__dropdown__item-link" href="https://mediakit.technologyreview.com/">Advertise with Us</a></li>
						</ul>
					</li>

					<!-- Redundent account menu implementation for devices -->
					
					<li class="navbar__item--primary navbar__item--primary--account navbar__item--phone">
						<a href="/login/?redirectTo=%2Fs%2F613331%2Fthe-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since%2F" class="navbar__item__link navbar__item__link--primary" rel="nofollow">Log in / Create and account</a>
					</li>
					
				</ul><!-- primary nav -->

				
				<ul class="navbar--tertiary">
					
					<li class="navbar__item--tertiary navbar__item--tertiary--subscribe"><a href="/subscribe/" class="navbar__item__link navbar__item__link--tertiary btn btn--primary">
						<span class="txt">Subscribe</span>
						<span class="btn--primary__icon"></span>
					</a></li>
					
				</ul><!-- tertiary nav -->
				

				<!-- Secondary Navbar -->
				<ul class="navbar--secondary">
					
					<li class="navbar__item--secondary navbar__item--secondary--login"><a href="/login/?redirectTo=%2Fs%2F613331%2Fthe-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since%2F" class="navbar__item__link navbar__item__link--secondary" rel="nofollow">Log in</a> / <a href="/login/?redirectTo=%2Fs%2F613331%2Fthe-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since%2F" class="navbar__item__link navbar__item__link--secondary" rel="nofollow">Create an account</a></li>
					
					<a data-toggle="search-form" rv-unless="entries.searchpage">
						<li class="navbar__item--secondary navbar__item--search dropdown-nav__item">
								<span class="navbar__desktop-search--text"><span rv-text="search.menuLabel">Search</span><i class="search-icon"></i></span>
						</li>
					</a>
				</ul><!-- secondary nav -->
				<ul class="navbar--search">
					<li class="navbar__item--search">
						<form id="search-form" class="navbar__mobile-search" action="/search/">
							<a class="navbar__mobile-search__close" data-search="close"></a>
							<input class="navbar__mobile-search__input" data-search="search-terms" type="text" name="s" autocomplete="off" placeholder="Search" rv-value="entries.params.query">
							<input class="navbar__mobile-search__button" data-search="submit" type="submit" value="">
							<p class="query-notice" rv-show="entries.loading" rv-if="entries"><span>Click search or press enter</span></p>
						</form>
					</li>
				</ul>
			</div><!-- header-navbar -->
		</div>
	</nav><!-- .navbar -->
</header>

		<!-- Leaderboard -->
		<div class="adunit ad--leaderboard"
	data-adunit="__site/__leaderboard"
	data-size-mapping="leaderboard"
	data-active="false">
</div>
	



	<!-- Ribbon -->
	

	

	<!-- Main -->
	<main class="site-content" role="main">
		<section data-entry-parent>
			<article data-entry-id="613331" data-type="article" class="article ">
				<div class="article-body">
					

	<!-- Article Topper: Horizontal -->
<div class="l-article-topper l-article-topper--horizontal" data-topper-layout="horizontal" data-topper-type="standard">

	<div class="article-topper__media-wrap">
		


<picture
	class="article-topper__image "
	
	data-iesrc="https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=1180&amp;cx=0&amp;cy=0&amp;cw=3000&amp;ch=1687"
	
>
			
				<source
					media="(min-width: 1024px)"
					srcset="https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=1180&amp;cx=0&amp;cy=0&amp;cw=3000&amp;ch=1687 1x,https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=2360&amp;cx=0&amp;cy=0&amp;cw=3000&amp;ch=1687 2x"
				>
			
		
			
				<source
					media="(min-width: 850px)"
					srcset="https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=1024&amp;cx=0&amp;cy=0&amp;cw=3000&amp;ch=1687 1x,https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=2048&amp;cx=0&amp;cy=0&amp;cw=3000&amp;ch=1687 2x"
				>
			
		
			
				<source
					media="(min-width: 550px)"
					srcset="https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=850&amp;cx=0&amp;cy=0&amp;cw=3000&amp;ch=1687 1x,https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=1700&amp;cx=0&amp;cy=0&amp;cw=3000&amp;ch=1687 2x"
				>
			
				<source
					media="(min-width: 401px)"
					srcset="https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=550&amp;cx=0&amp;cy=0&amp;cw=3000&amp;ch=1687 1x,https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=1100&amp;cx=0&amp;cy=0&amp;cw=3000&amp;ch=1687 2x"
				>
			
		
			
				<source
					media="(min-width: 0px)"
					srcset="https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=401&amp;cx=0&amp;cy=0&amp;cw=3000&amp;ch=1687 1x,https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=802&amp;cx=0&amp;cy=0&amp;cw=3000&amp;ch=1687 2x"
				>
			
		

		
			<img
				class="article-topper__image"
				src="https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=1180&amp;cx=0&amp;cy=0&amp;cw=3000&amp;ch=1687"
				srcset="https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=1180&amp;cx=0&amp;cy=0&amp;cw=3000&amp;ch=1687 1x,https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=2360&amp;cx=0&amp;cy=0&amp;cw=3000&amp;ch=1687 2x"
				
			>
			<div class="article-enlarge"></div></picture>


		

		
		<li class="article-topper__horizontal--illustration">Ms. Tech; computer: Wikimedia commons</li>
		

	</div>

	
	<div class="article-social-list article-social-list--topper">
	
<ul class="social-list addthis_toolbox" data-share-id="613331" addthis:url="https://www.technologyreview.com/s/613331/the-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since/" addthis:title="The first DDoS attack was 20 years ago. This is what we’ve learned since."><li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_facebook" data-event-category="addthis-custom" data-event-action="click" data-event-label="facebook"><i class="ion-social-facebook"></i></a>
	</li>
	<li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_twitter" data-event-category="addthis-custom" data-event-action="click" data-event-label="twitter"><i class="ion-social-twitter"></i></a>
	</li>
	<li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_reddit" data-event-category="addthis-custom" data-event-action="click" data-event-label="reddit"><i class="ion-social-reddit"></i></a>
	</li>
	<li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_linkedin" data-event-category="addthis-custom" data-event-action="click" data-event-label="linkedin"><i class="ion-social-linkedin"></i></a>
	</li>
	<li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_whatsapp" data-event-category="addthis-custom" data-event-action="click" data-event-label="whatsapp"><i class="ion-social-whatsapp"></i></a>
	</li>
	<li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_email" data-event-category="addthis-custom" data-event-action="click" data-event-label="email"><i class="ion-ios-email"></i></a>
	</li>
	
</ul>


	</div>
	

	<div class="article-topper__header-wrap">

		<div class="article-topper__hgroup">

			<div class="article-topper__hgroup--top">
				
					

  
    <h3 class="article-topper__topic">
      
      <a href="/topic/connectivity/" class="entry__term">Connectivity</a>
      

      

    </h3>
  



				

				<h1 class="article-topper__title">The first DDoS attack was 20 years ago. This is what we’ve learned since.</h1>

			</div>

			<div class="article-topper__hgroup--bottom">

				
				<h2 class="article-topper__subtitle">On the 20th anniversary of the first distributed denial of service attack, cybersecurity experts say the internet must be redesigned to prevent them.</h2>
				

				
				<ul class="article-topper__meta-info">
				

					
					<li class="article-topper__meta-item">
						by <!-- Article Topper: Byline -->

	
		<a href="/profile/emerging-technology-from-the-arxiv/">Emerging Technology from the arXiv</a>
	


					</li>
					

					
					<li class="article-topper__meta-item">April 18, 2019</li>
					

				</ul>

				

			</div>

		</div>

		

		<div class="article-social-list article-social-list--mobile">
		
<ul class="social-list addthis_toolbox" data-share-id="613331" addthis:url="https://www.technologyreview.com/s/613331/the-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since/" addthis:title="The first DDoS attack was 20 years ago. This is what we’ve learned since."><li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_facebook" data-event-category="addthis-custom" data-event-action="click" data-event-label="facebook"><i class="ion-social-facebook"></i></a>
	</li>
	<li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_twitter" data-event-category="addthis-custom" data-event-action="click" data-event-label="twitter"><i class="ion-social-twitter"></i></a>
	</li>
	<li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_reddit" data-event-category="addthis-custom" data-event-action="click" data-event-label="reddit"><i class="ion-social-reddit"></i></a>
	</li>
	<li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_linkedin" data-event-category="addthis-custom" data-event-action="click" data-event-label="linkedin"><i class="ion-social-linkedin"></i></a>
	</li>
	<li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_whatsapp" data-event-category="addthis-custom" data-event-action="click" data-event-label="whatsapp"><i class="ion-social-whatsapp"></i></a>
	</li>
	<li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_email" data-event-category="addthis-custom" data-event-action="click" data-event-label="email"><i class="ion-ios-email"></i></a>
	</li>
	
</ul>


		</div>

	</div>

	<div class="adunit ad--right-rail"
	data-adunit="__site/__square-rectangle"
	data-size-mapping="square--desktop"
	data-active="false">
</div>

</div>



	

<div class="article-body__content">

	

    

		<p>July 22, 1999, is an ominous date in the history of computing. On that day, a computer at the University of Minnesota suddenly came under attack from a network of 114 other computers infected with a malicious script called Trin00.</p>

    

		

<div class="l-automated-trending--ordered" data-widget-type="automated-trending" data-widget-layout="ordered">
	
	<h5 class="automated-trending__h">Recommended for You</h5>
	
	<ol class="automated-trending__tz-list">
		
			
				<li class="automated-trending--ordered__tz">
					<div class="automated-trending--ordered__tz__hgroup">
						<a href="/the-download/613340/activists-are-suing-canada-over-plans-to-build-a-smart-city-in-toronto/" class="automated-trending--ordered__tz__story-link" data-event-category="recirculation" data-event-action="click" data-event-label="popular-list-right-rail">Activists are suing Canada over plans to build a smart city in Toronto</a>
					</div>
				</li>
			
		
			
				<li class="automated-trending--ordered__tz">
					<div class="automated-trending--ordered__tz__hgroup">
						<a href="/the-download/613345/the-scientist-who-created-crispr-babies-is-on-times-most-influential-list-but/" class="automated-trending--ordered__tz__story-link" data-event-category="recirculation" data-event-action="click" data-event-label="popular-list-right-rail">The scientist who created CRISPR babies is on Time’s most-influential list—but not in a good way</a>
					</div>
				</li>
			
		
			
				<li class="automated-trending--ordered__tz">
					<div class="automated-trending--ordered__tz__hgroup">
						<a href="/the-download/613312/the-worlds-biggest-airplane-has-taken-its-first-flight/" class="automated-trending--ordered__tz__story-link" data-event-category="recirculation" data-event-action="click" data-event-label="popular-list-right-rail">The world’s biggest airplane has taken its first flight</a>
					</div>
				</li>
			
		
			
				<li class="automated-trending--ordered__tz">
					<div class="automated-trending--ordered__tz__hgroup">
						<a href="/the-download/613314/this-digital-scan-of-notre-dame-offers-hope-for-its-restoration-after/" class="automated-trending--ordered__tz__story-link" data-event-category="recirculation" data-event-action="click" data-event-label="popular-list-right-rail">This digital scan of Notre Dame offers hope for its restoration after the fire</a>
					</div>
				</li>
			
		
			
				<li class="automated-trending--ordered__tz">
					<div class="automated-trending--ordered__tz__hgroup">
						<a href="/s/613277/chinese-scientists-have-put-human-brain-genes-in-monkeysand-yes-they-may-be-smarter/" class="automated-trending--ordered__tz__story-link" data-event-category="recirculation" data-event-action="click" data-event-label="popular-list-right-rail">Chinese scientists have put human brain genes in monkeys—and yes, they may be smarter</a>
					</div>
				</li>
			
		
	</ol>
</div>

<div class="adunit ad--square-only ad--article-body"
	data-adunit="__site/__square-rectangle"
	data-size-mapping="square-rectangle--mobile"
	data-active="false">
</div>

    
      
		

		<p>This code caused the infected computers to send superfluous data packets to the university, overwhelming its computer and preventing it handling legitimate requests. In this way, the attack knocked out the university computer for&nbsp;two days.</p>

    

		<p>This was the world’s first distributed denial of service (DDoS) attack. But it didn’t take long for&nbsp;the tactic to spread. In the months that followed, numerous other websites became victims, including Yahoo, Amazon, and CNN. Each was flooded with data packets that prevented it from accepting legitimate traffic. And in each case, the malicious data packets came from a network of infected computers.</p>

    

		


	


<figure class="l-article-img l-article-img--text-col"
	data-widget-type="imageset"
	data-widget-layout="text-col">

	

	
		

		
			


<picture
	class="article-img article-img--text-col "
	
	data-iesrc="https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=600&amp;cx=0&amp;cy=0&amp;cw=800&amp;ch=1131"
	
>
			
				<source
					media="(min-width: 1024px)"
					srcset="https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=600&amp;cx=0&amp;cy=0&amp;cw=800&amp;ch=1131 1x,https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=1200&amp;cx=0&amp;cy=0&amp;cw=800&amp;ch=1131 2x"
				>
			
		
			
				<source
					media="(min-width: 850px)"
					srcset="https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=1024&amp;cx=0&amp;cy=0&amp;cw=800&amp;ch=1131 1x,https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=2048&amp;cx=0&amp;cy=0&amp;cw=800&amp;ch=1131 2x"
				>
			
		
			
				<source
					media="(min-width: 550px)"
					srcset="https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=850&amp;cx=0&amp;cy=0&amp;cw=800&amp;ch=1131 1x,https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=1700&amp;cx=0&amp;cy=0&amp;cw=800&amp;ch=1131 2x"
				>
			
				<source
					media="(min-width: 401px)"
					srcset="https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=550&amp;cx=0&amp;cy=0&amp;cw=800&amp;ch=1131 1x,https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=1100&amp;cx=0&amp;cy=0&amp;cw=800&amp;ch=1131 2x"
				>
			
		
			
				<source
					media="(min-width: 0px)"
					srcset="https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=401&amp;cx=0&amp;cy=0&amp;cw=800&amp;ch=1131 1x,https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=802&amp;cx=0&amp;cy=0&amp;cw=800&amp;ch=1131 2x"
				>
			
		

		
			<img
				class="article-img article-img--text-col"
				src="https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=600&amp;cx=0&amp;cy=0&amp;cw=800&amp;ch=1131"
				srcset="https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=600&amp;cx=0&amp;cy=0&amp;cw=800&amp;ch=1131 1x,https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=1200&amp;cx=0&amp;cy=0&amp;cw=800&amp;ch=1131 2x"
				
			>
			<div class="article-enlarge"></div></picture>

		

		

	

		
</figure>


    

		<p>Since then, DDoS attacks have become common. Malicious actors also make a lucrative trade in extorting protection money from websites they threaten to attack. They even sell their services on the dark web. A 24-hour DDoS attack against a single target can cost as little as $400. &nbsp;</p>

    

		<p>But the cost to the victim can be huge in terms of lost revenue or damaged reputation. That in turn has created a market for cyberdefense that protects against these kinds of attacks. In 2018, this market was worth a staggering €2 billion. All this raises the important question of whether more can be done to defend against DDoS attacks.</p>

    

		
<div class="l-cta--left">
    <div class="cta--left">
    	<div class="cta__box">
        
			  
          
          <div class="cta__title" cta-type="fwd_economy">Sign up for <strong>fwd: Economy</strong></div>
          <div class="cta__dek" cta-type="fwd_economy">Your guide to growth and prosperity in the age of technology</div>
	    	
	    	<div class="article__newsletter-form">
          <script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2.js"></script>
          <script>
            hbspt.forms.create({
              portalId: "4518541",
              formId: "22ad05c5-9a7c-4a33-98f5-9b514240171f"
            });
          </script>
	    	</div>
	    </div>
    </div>
</div>


    

		<p>Today, 20 years after the first attack, Eric Osterweil from George Mason University in Virginia and colleagues explore the nature of DDoS attacks, how they have evolved, and whether there are foundational problems with network architecture that need to be addressed to make it safer. The answers, they say, are far from straightforward: “The landscape of cheap, compromisable, bots has only become more fertile to miscreants, and more damaging to Internet service operators.”</p>

    

		<p>First some background. DDoS attacks usually unfold in stages. In the first stage, a malicious intruder infects a computer with software designed to spread across a network. This first computer is known as the “master,” because it can control any subsequent computers that become infected. The other infected computers carry out the actual attack and are known as “daemons.”</p>

    

		<p>Common victims at this first stage are university or college computer networks, because they are connected to a wide range of other devices.</p>

    

		<p>A DDoS attack begins when the master computer sends a command to the daemons that includes the address of the target. The daemons then start sending large numbers of data packets to this address. The goal is to overwhelm the target with traffic for the duration of the attack. The largest attacks today send malicious data packets at a rate of terabits per second.</p>

    

		<p>The attackers often go to considerable lengths to hide their location and identity. For example, the daemons often use a technique called IP address spoofing to hide their address on the internet. Master computers can also be difficult to trace because they need only send a single command to trigger an attack. And an attacker can choose to use daemons only in countries that are difficult to access, even though they themselves may be located elsewhere.</p>

    

		<p>Defending against these kinds of attacks is hard because it requires concerted actions by a range of operators. The first line of defense is to prevent the creation of the daemon network in the first place. This requires system administrators to regularly update and patch the software they use and to encourage good hygiene among users of their network—for example, regularly changing passwords, using personal firewalls, and so on.</p>

    

		<p>Internet service providers can also provide some defense. Their role is in forwarding data packets from one part of a network to another, depending on the address in each data packet’s header. This is often done with little or no consideration for where the data packet came from.</p>

    

		<p>But that could change. The header contains not only the target address but also the source address. So in theory, it is possible for an ISP to examine the source address and block packets that contain obviously spoofed sources.</p>

    

		<p>However, this is computationally expensive and time consuming. And since the ISPs are not necessarily the targets in a DDoS attack, they have limited incentive to employ expensive mitigation procedures.</p>

    

		<p>Finally, the target itself can take steps to mitigate the effects of an attack. One obvious step is to filter out the bad data packets as they arrive. That works if they are easy to spot and if the computational resources are in place to cope with the volume of malicious traffic.</p>

    

		<p>But these resources are expensive and must be continually updated with the latest threats. They sit unused most of the time, springing into action only when an attack occurs. And even then, they may not cope with the biggest attacks. So this kind of mitigation is rare.</p>

    

		<p>Another option is to outsource the problem to a cloud-based service that is better equipped to handle such threats. This centralizes the problems of DDoS mitigation in “scrubbing centers,” and many cope well. But even these can have trouble dealing with the largest attacks.</p>

    

		<p>All that raises the question of whether more can be done. “How can our network infrastructure be enhanced to address the principles that enable the DDoS problem?” ask Osterweil and co. And they say the 20th&nbsp;anniversary of the first attack should offer a good opportunity to study the problem in more detail. “We believe that what is needed are investigations into what fundamentals enable and exacerbate DDoS,” they say.</p>

    

		<p>One important observation about DDoS attacks is&nbsp;that the attack and the defense are asymmetric. A DDoS attack is typically launched from many daemons all over the world, and yet the defense takes place largely at a single location—the node that is under attack.</p>

    

		<p>An important question is whether networks could or should be modified to include a kind of distributed defense against these attacks. &nbsp;For example, one way forward might be to make it easier for ISPs to filter out spoofed data packets.</p>

    

		<p>Another idea is to make data packets traceable as they travel across the internet. Each ISP could mark a sample of data packets—perhaps one in 20,000—as they are routed so that their journey could&nbsp;later be reconstructed. That would allow the victim and law enforcement agencies to track the source of an attack, even after it has ended.</p>

    

		<p>These and other ideas have the potential to make the internet a safer place. But they require agreement and willingness to act. Osterweil and co think the time is ripe for action: “This is a call to action: the research community is our best hope and best qualified to take up this call.”</p>

    

		<p>Ref: <a href="https://arxiv.org/abs/1904.02739">arxiv.org/abs/1904.02739</a> : 20 Years of DDoS:&nbsp;A Call to Action</p>
	
		<div class="callout--tagged-event-promo" desc="in-story-promo-emtech-next-reg">
			<p class="callout__copy">Learn from the humans leading the way in connectivity at EmTech Next. Register Today!<br>June 11-12, 2019<br>Cambridge, MA</p>
			
			<a href="https://events.technologyreview.com/emtech/next/19/?utm_medium=trsite&amp;utm_source=instory&amp;utm_campaign=emtech_next_2019.unpaid.acquisition&amp;utm_content=fact&amp;discount=TAGNXINST#section-register" class="callout__link" data-event-category="promoTracking" data-event-action="click" data-event-label="in-story-promo-emtech-next-reg">Register now <span class="callout__cta-icon"></span></a><br>
			
		</div>
	
</div>

<div class="article-enlarge__modal">





<!-- Widget: Slideshow -->
<div data-widget-type="slideshow" class="article-img-enlarge-gallery-container swiper-container">
	<div class="swiper-wrapper-outer">
		<div class="article-img-enlarge-gallery-wrapper swiper-wrapper">


	







<div class="swiper-slide">
	<div class="swiper-slide__wrapper">
		
		<picture>
			
<source
	media="(min-width: 850px)"
	real-srcset="https://cdn.technologyreview.com/i/images/arxivddos2.jpg?cx=0&cy=0&cw=3000&ch=1687&sw=1180 1x, https://cdn.technologyreview.com/i/images/arxivddos2.jpg?cx=0&cy=0&cw=3000&ch=1687&sw=2360 2x"
/>

			
<source
	media="(min-width: 550px)"
	real-srcset="https://cdn.technologyreview.com/i/images/arxivddos2.jpg?cx=0&cy=0&cw=3000&ch=1687&sw=850 1x, https://cdn.technologyreview.com/i/images/arxivddos2.jpg?cx=0&cy=0&cw=3000&ch=1687&sw=1700 2x"
/>

			
<source
	media="(min-width: 401px)"
	real-srcset="https://cdn.technologyreview.com/i/images/arxivddos2.jpg?cx=0&cy=0&cw=3000&ch=1687&sw=550 1x, https://cdn.technologyreview.com/i/images/arxivddos2.jpg?cx=0&cy=0&cw=3000&ch=1687&sw=1100 2x"
/>

			<img
				class="article-img article-img--enlarge"
				real-srcset="https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=3000&cx=0&cy=0&cw=3000&ch=1687 1x, https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=3000&cx=0&cy=0&cw=3000&ch=1687 2x"
 				alt=""
				real-src="https://cdn.technologyreview.com/i/images/arxivddos2.jpg?sw=3000&cx=0&cy=0&cw=3000&ch=1687"
			/>
			<div class="enlarge-close"></div>
		</picture>

		

		<figcaption class="article-cap">
			</strong>
			
		</figcaption>
	</div>
</div>



						


	







<div class="swiper-slide">
	<div class="swiper-slide__wrapper">
		
		<picture>
			
<source
	media="(min-width: 850px)"
	real-srcset="https://cdn.technologyreview.com/i/images/ddosattack.svg.png?cx=0&cy=0&cw=800&ch=1131&sw=1180 1x, https://cdn.technologyreview.com/i/images/ddosattack.svg.png?cx=0&cy=0&cw=800&ch=1131&sw=2360 2x"
/>

			
<source
	media="(min-width: 550px)"
	real-srcset="https://cdn.technologyreview.com/i/images/ddosattack.svg.png?cx=0&cy=0&cw=800&ch=1131&sw=850 1x, https://cdn.technologyreview.com/i/images/ddosattack.svg.png?cx=0&cy=0&cw=800&ch=1131&sw=1700 2x"
/>

			
<source
	media="(min-width: 401px)"
	real-srcset="https://cdn.technologyreview.com/i/images/ddosattack.svg.png?cx=0&cy=0&cw=800&ch=1131&sw=550 1x, https://cdn.technologyreview.com/i/images/ddosattack.svg.png?cx=0&cy=0&cw=800&ch=1131&sw=1100 2x"
/>

			<img
				class="article-img article-img--enlarge"
				real-srcset="https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=800&cx=0&cy=0&cw=800&ch=1131 1x, https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=800&cx=0&cy=0&cw=800&ch=1131 2x"
 				alt=""
				real-src="https://cdn.technologyreview.com/i/images/ddosattack.svg.png?sw=800&cx=0&cy=0&cw=800&ch=1131"
			/>
			<div class="enlarge-close"></div>
		</picture>

		

		<figcaption class="article-cap">
			</strong>
			
		</figcaption>
	</div>
</div>



					

			

			
		</div>		
	</div>
	
	<div class="enlarge-gallery-controls__container">
		<button class="enlarge-gallery-swiper-button enlarge-gallery-swiper-button-prev"></button>
		<div class="enlarge-gallery-swiper-index-back"><div class="enlarge-gallery-swiper-index-front"><div class="enlarge-swiper-pagination-fraction"></div></div></div>
		<button class="enlarge-gallery-swiper-button enlarge-gallery-swiper-button-next"></button>
	</div>
</div><!-- // end [data-widget-type="slideshow"] --></div>


	<footer class="article-footer">

	
	<div class="article-footer__ad">
		<div class="adunit ad--square-only"
	data-adunit="__site/__square-only"
	data-size-mapping="footer"
	data-active="false">
</div>
	</div>
	

	<div class="article-footer__main">
		<div class="article-footer__group article-footer__terms">
			<div class="sharing--footer">
				<h3 class="article-footer__term-title">Share</h3>
			
<ul class="social-list addthis_toolbox" data-share-id="613331" addthis:url="https://www.technologyreview.com/s/613331/the-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since/" addthis:title="The first DDoS attack was 20 years ago. This is what we’ve learned since."><li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_facebook" data-event-category="addthis-custom" data-event-action="click" data-event-label="facebook"><i class="ion-social-facebook"></i></a>
	</li>
	<li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_twitter" data-event-category="addthis-custom" data-event-action="click" data-event-label="twitter"><i class="ion-social-twitter"></i></a>
	</li>
	<li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_reddit" data-event-category="addthis-custom" data-event-action="click" data-event-label="reddit"><i class="ion-social-reddit"></i></a>
	</li>
	<li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_linkedin" data-event-category="addthis-custom" data-event-action="click" data-event-label="linkedin"><i class="ion-social-linkedin"></i></a>
	</li>
	<li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_whatsapp" data-event-category="addthis-custom" data-event-action="click" data-event-label="whatsapp"><i class="ion-social-whatsapp"></i></a>
	</li>
	<li class="social-list__item">
		<a href="#" class="social-list__link addthis_button_email" data-event-category="addthis-custom" data-event-action="click" data-event-label="email"><i class="ion-ios-email"></i></a>
	</li>
	
</ul>


			</div>

			

			
		</div><!-- // end .article-footer__terms -->

		
		<div class="article-footer__group article-footer__author">

			
			<div class="article-footer__author__portrait-mod">
				<img class="article-footer__author__portrait" src="https://cdn.technologyreview.com/i/profiles/avatars/Xb-logo-circle.png?sw=75" alt="Emerging Technology from the arXiv">
			</div>
			

			<div class="article-footer__author__text article-footer__author__text-with-avatar">
				<p class="article-footer__author__name"><a href="/profile/emerging-technology-from-the-arxiv/">Emerging Technology from the arXiv</a> <span class="article-footer__author__title"></span></p>
				
				<p class="article-footer__author_bio">Emerging Technology from the arXiv covers the latest ideas and technologies that appear on the Physics arXiv preprint server. It is part of the Physics arXiv Blog.

Email:<span class="truncate__trigger">&hellip; <a href="#" data-truncate="trigger">More</a></span><span data-truncate="extended" class="truncate__extended"> <a href="mailto:KentuckyFC@arxivblog.com">KentuckyFC@arxivblog.com</a><br /><br /><a class="rss" href="https://www.technologyreview.com/contributor/emerging-technology-from-the-arxiv/rss/">Subscribe to the Physics arXiv Blog RSS Feed</a>.</span></p>
				
			</div>
		</div><!-- // end .article-footer__author -->
		</div><!-- // end .article-footer -->
</footer>



				</div>
			</article>

			<section class="paywall" class="entry-login container"></section>

			<section class="l-fullwidth-interstitial-ad">
				<div class="adunit ad--large"
	data-adunit="__site/__fullwidth-interstitial"
	data-size-mapping="fullwidth-interstitial"
	data-active="false">
</div>
			</section>

			<!-- Related Videos -->
			

<section class="l-related-videos">

	<header class="related-videos__header">
		<h3 class="related-videos__header__title">Related Video</h3>
		<p class="related-videos__header__link"><a href="/videos/">More videos</a></p>
	</header>

	<div class="l-related-videos__container">
	
		
		<div class="related-video">
			
			<a class="related-video__image-link" href="/video/613028/10-breakthrough-technologies-of-2019-curated-by-bill-gates/" data-event-category="relatedvideo" data-event-action="click" data-event-label="/video/613028/10-breakthrough-technologies-of-2019-curated-by-bill-gates/">
				<div class="related-video__image-wrapper">
					<span class="related-video__play-border">
						<span class="related-video__play-button"></span>
					</span>
					


<picture
	class="related-video__image "
	
><img
			class="related-video__image lozad"
			data-src="https://cdn.technologyreview.com/i/ooyala/djOTBjaDE6fBs-K_-_COkznNjSgkfyM2_0.jpg?sw=512"
			data-srcset="https://cdn.technologyreview.com/i/ooyala/djOTBjaDE6fBs-K_-_COkznNjSgkfyM2_0.jpg?sw=512 1x,https://cdn.technologyreview.com/i/ooyala/djOTBjaDE6fBs-K_-_COkznNjSgkfyM2_0.jpg?sw=1024 2x"></picture>

				</div>
			</a>
			
			<p class="related-video__topic">
				
					Connectivity
				
			</p>

			<a href="/video/613028/10-breakthrough-technologies-of-2019-curated-by-bill-gates/"><div class="related-video__title" >10 Breakthrough Technologies of 2019, curated by Bill Gates <span class="related-video__duration">17:18</span></div></a>
		</div>
		
	
		
		<div class="related-video">
			
			<a class="related-video__image-link" href="https://events.technologyreview.com/video/watch/urban-ecosystems-reynolds-jacob-wissink/" data-event-category="relatedvideo" data-event-action="click" data-event-label="https://events.technologyreview.com/video/watch/urban-ecosystems-reynolds-jacob-wissink/">
				<div class="related-video__image-wrapper">
					<span class="related-video__play-border">
						<span class="related-video__play-button"></span>
					</span>
					


<picture
	class="related-video__image "
	
><img
			class="related-video__image lozad"
			data-src="https://cdn.technologyreview.com/i/ooyala/1kNXdoZjE6gXZH-MjeSS3rd4hLACqTVi_0.jpg?sw=512"
			data-srcset="https://cdn.technologyreview.com/i/ooyala/1kNXdoZjE6gXZH-MjeSS3rd4hLACqTVi_0.jpg?sw=512 1x,https://cdn.technologyreview.com/i/ooyala/1kNXdoZjE6gXZH-MjeSS3rd4hLACqTVi_0.jpg?sw=1024 2x"></picture>

				</div>
			</a>
			
			<p class="related-video__topic">
				
					Connectivity
				
			</p>

			<a href="https://events.technologyreview.com/video/watch/urban-ecosystems-reynolds-jacob-wissink/"><div class="related-video__title" >Technology, Work, and Urban Ecosystems: How Should Cities and Regions Respond? <span class="related-video__duration">31:37</span></div></a>
		</div>
		
	
		
		<div class="related-video">
			
			<a class="related-video__image-link" href="https://events.technologyreview.com/video/watch/greg-mark-markforged-3d-printing/" data-event-category="relatedvideo" data-event-action="click" data-event-label="https://events.technologyreview.com/video/watch/greg-mark-markforged-3d-printing/">
				<div class="related-video__image-wrapper">
					<span class="related-video__play-border">
						<span class="related-video__play-button"></span>
					</span>
					


<picture
	class="related-video__image "
	
><img
			class="related-video__image lozad"
			data-src="https://cdn.technologyreview.com/i/ooyala/pueXRoZjE6dfbXkF6B5KyQknPwZXYK5q_0.jpg?sw=512"
			data-srcset="https://cdn.technologyreview.com/i/ooyala/pueXRoZjE6dfbXkF6B5KyQknPwZXYK5q_0.jpg?sw=512 1x,https://cdn.technologyreview.com/i/ooyala/pueXRoZjE6dfbXkF6B5KyQknPwZXYK5q_0.jpg?sw=1024 2x"></picture>

				</div>
			</a>
			
			<p class="related-video__topic">
				
					Connectivity
				
			</p>

			<a href="https://events.technologyreview.com/video/watch/greg-mark-markforged-3d-printing/"><div class="related-video__title" >The Next Generation of 3-D Printing <span class="related-video__duration">20:25</span></div></a>
		</div>
		
	
		
		<div class="related-video">
			
			<a class="related-video__image-link" href="https://events.technologyreview.com/video/watch/katie-finnegan-walmart-future-retail/" data-event-category="relatedvideo" data-event-action="click" data-event-label="https://events.technologyreview.com/video/watch/katie-finnegan-walmart-future-retail/">
				<div class="related-video__image-wrapper">
					<span class="related-video__play-border">
						<span class="related-video__play-button"></span>
					</span>
					


<picture
	class="related-video__image "
	
><img
			class="related-video__image lozad"
			data-src="https://cdn.technologyreview.com/i/ooyala/5qeXRoZjE68hyXUPQPdGHMx4OuAhpS_I_0.jpg?sw=512"
			data-srcset="https://cdn.technologyreview.com/i/ooyala/5qeXRoZjE68hyXUPQPdGHMx4OuAhpS_I_0.jpg?sw=512 1x,https://cdn.technologyreview.com/i/ooyala/5qeXRoZjE68hyXUPQPdGHMx4OuAhpS_I_0.jpg?sw=1024 2x"></picture>

				</div>
			</a>
			
			<p class="related-video__topic">
				
					Connectivity
				
			</p>

			<a href="https://events.technologyreview.com/video/watch/katie-finnegan-walmart-future-retail/"><div class="related-video__title" >Walmart’s Store No. 8: Transforming the Future of Retail <span class="related-video__duration">24:53</span></div></a>
		</div>
		
	
	</div>

</section>



			
					<section class="">

<div class="l-automated-trending-mobile--ordered">
	
	<h5 class="automated-trending__h">Recommended for You</h5>
	
	<ol class="automated-trending__tz-list">
	
		
			<li class="automated-trending--ordered__tz">
				<div class="automated-trending--ordered__tz__hgroup">
					<a href="/the-download/613340/activists-are-suing-canada-over-plans-to-build-a-smart-city-in-toronto/" class="automated-trending--ordered__tz__story-link" data-event-category="recirculation" data-event-action="click" data-event-label="readnext-list">Activists are suing Canada over plans to build a smart city in Toronto</a>
				</div>
			</li>
		
	
		
			<li class="automated-trending--ordered__tz">
				<div class="automated-trending--ordered__tz__hgroup">
					<a href="/the-download/613345/the-scientist-who-created-crispr-babies-is-on-times-most-influential-list-but/" class="automated-trending--ordered__tz__story-link" data-event-category="recirculation" data-event-action="click" data-event-label="readnext-list">The scientist who created CRISPR babies is on Time’s most-influential list—but not in a good way</a>
				</div>
			</li>
		
	
		
			<li class="automated-trending--ordered__tz">
				<div class="automated-trending--ordered__tz__hgroup">
					<a href="/the-download/613312/the-worlds-biggest-airplane-has-taken-its-first-flight/" class="automated-trending--ordered__tz__story-link" data-event-category="recirculation" data-event-action="click" data-event-label="readnext-list">The world’s biggest airplane has taken its first flight</a>
				</div>
			</li>
		
	
		
			<li class="automated-trending--ordered__tz">
				<div class="automated-trending--ordered__tz__hgroup">
					<a href="/the-download/613314/this-digital-scan-of-notre-dame-offers-hope-for-its-restoration-after/" class="automated-trending--ordered__tz__story-link" data-event-category="recirculation" data-event-action="click" data-event-label="readnext-list">This digital scan of Notre Dame offers hope for its restoration after the fire</a>
				</div>
			</li>
		
	
		
			<li class="automated-trending--ordered__tz">
				<div class="automated-trending--ordered__tz__hgroup">
					<a href="/s/613277/chinese-scientists-have-put-human-brain-genes-in-monkeysand-yes-they-may-be-smarter/" class="automated-trending--ordered__tz__story-link" data-event-category="recirculation" data-event-action="click" data-event-label="readnext-list">Chinese scientists have put human brain genes in monkeys—and yes, they may be smarter</a>
				</div>
			</li>
		
	
	</ol>
</div>




<section>
				

		</section>
	</main>

	<!-- Read More -->
	

<section class="rm" data-type="">

	<header class="rm__header">

		<div class="rm__header__heading">More from Connectivity</div>
		

		
		<p class="rm__header__subheading">What it means to be constantly connected with each other and vast sources of information.<p>
		

		

	</header>

	<ul class="rm__articles-list" data-entryset-value="">

	
		

		<li class="rm__article rm__article--img">

			<div class="rm__article__text">

				<a href="/s/613311/mapping-the-world-in-3d-will-let-us-paint-streets-with-augmented-reality/" data-event-category="readnext" data-event-action="click" data-event-label="item_1" data-entryset-link><div class="rm__article__text__title" >Mapping the world in 3D will let us paint streets with augmented reality</div></a>

				<p class="rm__article__text__dek">Machines need an exact digital replica of our world if we’re going to get true, location-specific AR—or accurate robot food deliveries.</p>

				
				<p class="rm__article__text__byline">by 
	
		
			Charlotte Jee
		
	
</p>
				

			</div>

			
			<div class="l-rm__article__thumbnail"><a href="/s/613311/mapping-the-world-in-3d-will-let-us-paint-streets-with-augmented-reality/" data-event-category="readnext" data-event-action="click" data-event-label="item_1" data-entryset-link>


<picture
	class="rm__article__thumbnail lozad"
	
	data-iesrc="https://cdn.technologyreview.com/i/images/scapetopper.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125"
	
>
			
				<source
					media="(min-width: 1024px)"
					srcset="https://cdn.technologyreview.com/i/images/scapetopper.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 1x,https://cdn.technologyreview.com/i/images/scapetopper.jpg?sw=640&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 2x"
				>
			
		
			
				<source
					media="(min-width: 850px)"
					srcset="https://cdn.technologyreview.com/i/images/scapetopper.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 1x,https://cdn.technologyreview.com/i/images/scapetopper.jpg?sw=640&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 2x"
				>
			
		
			
				<source
					media="(min-width: 550px)"
					srcset="https://cdn.technologyreview.com/i/images/scapetopper.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 1x,https://cdn.technologyreview.com/i/images/scapetopper.jpg?sw=640&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 2x"
				>
			
				<source
					media="(min-width: 401px)"
					srcset="https://cdn.technologyreview.com/i/images/scapetopper.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 1x,https://cdn.technologyreview.com/i/images/scapetopper.jpg?sw=640&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 2x"
				>
			
		
			
				<source
					media="(min-width: 0px)"
					srcset="https://cdn.technologyreview.com/i/images/scapetopper.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 1x,https://cdn.technologyreview.com/i/images/scapetopper.jpg?sw=640&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 2x"
				>
			
		

		</picture>
</a></div>
			
		</li>

	
		

		<li class="rm__article rm__article--img">

			<div class="rm__article__text">

				<a href="/s/613291/the-first-study-of-a-twin-in-space-looks-like-good-news-for-a-trip-to-mars/" data-event-category="readnext" data-event-action="click" data-event-label="item_2" data-entryset-link><div class="rm__article__text__title" >The first study of a twin in space looks like good news for a trip to Mars</div></a>

				<p class="rm__article__text__dek">Thanks to twin astronauts, we now have our first solid evidence of how the human body responds to long-term spaceflight—and it’s thrown up some mysteries.</p>

				
				<p class="rm__article__text__byline">by 
	
		
			Erin Winick
		
	
</p>
				

			</div>

			
			<div class="l-rm__article__thumbnail"><a href="/s/613291/the-first-study-of-a-twin-in-space-looks-like-good-news-for-a-trip-to-mars/" data-event-category="readnext" data-event-action="click" data-event-label="item_2" data-entryset-link>


<picture
	class="rm__article__thumbnail lozad"
	
	data-iesrc="https://cdn.technologyreview.com/i/images/twinsstudynasa.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125"
	
>
			
				<source
					media="(min-width: 1024px)"
					srcset="https://cdn.technologyreview.com/i/images/twinsstudynasa.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 1x,https://cdn.technologyreview.com/i/images/twinsstudynasa.jpg?sw=640&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 2x"
				>
			
		
			
				<source
					media="(min-width: 850px)"
					srcset="https://cdn.technologyreview.com/i/images/twinsstudynasa.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 1x,https://cdn.technologyreview.com/i/images/twinsstudynasa.jpg?sw=640&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 2x"
				>
			
		
			
				<source
					media="(min-width: 550px)"
					srcset="https://cdn.technologyreview.com/i/images/twinsstudynasa.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 1x,https://cdn.technologyreview.com/i/images/twinsstudynasa.jpg?sw=640&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 2x"
				>
			
				<source
					media="(min-width: 401px)"
					srcset="https://cdn.technologyreview.com/i/images/twinsstudynasa.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 1x,https://cdn.technologyreview.com/i/images/twinsstudynasa.jpg?sw=640&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 2x"
				>
			
		
			
				<source
					media="(min-width: 0px)"
					srcset="https://cdn.technologyreview.com/i/images/twinsstudynasa.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 1x,https://cdn.technologyreview.com/i/images/twinsstudynasa.jpg?sw=640&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 2x"
				>
			
		

		</picture>
</a></div>
			
		</li>

	
		

		<li class="rm__article rm__article--img">

			<div class="rm__article__text">

				<a href="/s/613286/the-anatomy-of-online-dating-has-been-revealed-in-unprecedented-detail/" data-event-category="readnext" data-event-action="click" data-event-label="item_3" data-entryset-link><div class="rm__article__text__title" >Online dating sites give us an intriguing look at how we meet people now</div></a>

				<p class="rm__article__text__dek">More than 300 million people use online dating sites. We’re now beginning to get a look at how these complex networks work.</p>

				
				<p class="rm__article__text__byline">by 
	
		
			Emerging Technology from the arXiv
		
	
</p>
				

			</div>

			
			<div class="l-rm__article__thumbnail"><a href="/s/613286/the-anatomy-of-online-dating-has-been-revealed-in-unprecedented-detail/" data-event-category="readnext" data-event-action="click" data-event-label="item_3" data-entryset-link>


<picture
	class="rm__article__thumbnail lozad"
	
	data-iesrc="https://cdn.technologyreview.com/i/images/arxivonlinedating.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125"
	
>
			
				<source
					media="(min-width: 1024px)"
					srcset="https://cdn.technologyreview.com/i/images/arxivonlinedating.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 1x,https://cdn.technologyreview.com/i/images/arxivonlinedating.jpg?sw=640&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 2x"
				>
			
		
			
				<source
					media="(min-width: 850px)"
					srcset="https://cdn.technologyreview.com/i/images/arxivonlinedating.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 1x,https://cdn.technologyreview.com/i/images/arxivonlinedating.jpg?sw=640&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 2x"
				>
			
		
			
				<source
					media="(min-width: 550px)"
					srcset="https://cdn.technologyreview.com/i/images/arxivonlinedating.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 1x,https://cdn.technologyreview.com/i/images/arxivonlinedating.jpg?sw=640&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 2x"
				>
			
				<source
					media="(min-width: 401px)"
					srcset="https://cdn.technologyreview.com/i/images/arxivonlinedating.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 1x,https://cdn.technologyreview.com/i/images/arxivonlinedating.jpg?sw=640&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 2x"
				>
			
		
			
				<source
					media="(min-width: 0px)"
					srcset="https://cdn.technologyreview.com/i/images/arxivonlinedating.jpg?sw=320&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 1x,https://cdn.technologyreview.com/i/images/arxivonlinedating.jpg?sw=640&amp;cx=0&amp;cy=0&amp;cw=2000&amp;ch=1125 2x"
				>
			
		

		</picture>
</a></div>
			
		</li>

	

	</ul>

	
	
	<footer class="rm__footer">
		<p class="rm__footer__link"><a href="/topic/connectivity/" data-event-category="readnext" data-event-action="click" data-event-label="more">More from Connectivity</a></p>
	</footer>
	

</section>




	
<aside class="article-sponsored-content-list">
	<div class="article-sponsored-content-list__wrapper">
		<div class="article-sponsored-content-list__title">From Our Advertisers</div>
		<ul class="article-sponsored-content-list__list">
			
			<li class="article-sponsored-content-list__item">
				<a href="/s/612364/digital-transformation-sparks-innovation-in-networking/" class="article-sponsored-content-list__item__link" data-event-category="ad_sales" data-event-action="click" data-event-label="article_link_list">
					
					<p class="article-sponsored-content-list__item__sponsor">
						
							In association with
						
						<strong class="article-sponsored-content-list__item__sponsor__name">VMware</strong>
					</p>
					
					<div class="article-sponsored-content-list__item__hed">Digital transformation sparks innovation in networking</div>
				</a>
			</li>
			
			<li class="article-sponsored-content-list__item">
				<a href="/s/612244/for-data-savvy-marketers-theres-a-new-keyword-intent/" class="article-sponsored-content-list__item__link" data-event-category="ad_sales" data-event-action="click" data-event-label="article_link_list">
					
					<p class="article-sponsored-content-list__item__sponsor">
						
							In association with
						
						<strong class="article-sponsored-content-list__item__sponsor__name">Google</strong>
					</p>
					
					<div class="article-sponsored-content-list__item__hed">For data-savvy marketers, there’s a new keyword: Intent</div>
				</a>
			</li>
			
			<li class="article-sponsored-content-list__item">
				<a href="/s/611994/machine-learning-teaches-marketers-to-cultivate-a-growth-mindset/" class="article-sponsored-content-list__item__link" data-event-category="ad_sales" data-event-action="click" data-event-label="article_link_list">
					
					<p class="article-sponsored-content-list__item__sponsor">
						
							In association with
						
						<strong class="article-sponsored-content-list__item__sponsor__name">Google</strong>
					</p>
					
					<div class="article-sponsored-content-list__item__hed">Machine learning teaches marketers to cultivate a growth mindset</div>
				</a>
			</li>
			
			<li class="article-sponsored-content-list__item">
				<a href="https://www.technologyreview.com/s/611996/machine-learning-driven-analytics-key-to-digital-transformation/" class="article-sponsored-content-list__item__link" data-event-category="ad_sales" data-event-action="click" data-event-label="article_link_list">
					
					<p class="article-sponsored-content-list__item__sponsor">
						
							In association with
						
						<strong class="article-sponsored-content-list__item__sponsor__name">Oracle and Intel</strong>
					</p>
					
					<div class="article-sponsored-content-list__item__hed">Machine learning - driven analytics: Key to digital transformation</div>
				</a>
			</li>
			
		</ul>
	</div>
</aside>



	
		<!-- Insider promo -->
		








  


<div class="l-pricing l-pricing--menu-only" data-abtest-variant="print + all access digital">

	<div class="pricing__heading">
		Want more award-winning journalism?
		
			Subscribe to Print + All Access Digital.
		
	</div>

	<div id="pricing">

		<div class="l-pricing__menu l-pricing__menu--menu-only">
			<ul class="pricing__menu">
				
				
					
					<li class="pricing__menu__tier pricing__menu__tier--print_digital" data-tier="print_digital">
						<div class="pricing__menu__tier__heading">
							Print + All Access Digital
							<span class="pricing__menu__tier__price" data-onload="fadein">{! insider.prices.print_digital !}<span rv-if="insider.diffIntlPrice.print_digital">*</span></span>
							
						</div>
						<p class="pricing__menu__tier__pricing-label" rv-show="insider.display.menuOptionsLabel" data-onload="fadein">
							{! insider.display.menuOptionsLabel !}
						</p>
						<p class="pricing__menu__tier__description" data-onload="fadein">
							The best of MIT Technology Review in print and online, plus unlimited access to our online archive, an ad-free web experience, discounts to MIT Technology Review events, and The Download delivered to your email in-box each weekday.
						</p>

						<div class="pricing__menu__tier__cta-block" data-onload="fadein">
							<a rv-href="insider.buttons.print_digital.buttonURL" class="btn btn--primary--transparent pricing__menu__tier__cta" rv-class-btn--activated="insider.buttons.print_digital.buttonClassActivated" rv-class-btn--group-activated="insider.buttons.print_digital.buttonClassGroupActivated" data-event-category="story-footer-insider-promo" data-event-action="click" data-event-label="print + all access digital">{! insider.buttons.print_digital.buttonText !}<span class="btn--primary--transparent__icon">
<svg class="btn__icon--angle-arrow" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 10.1 10.1" enable-background="new 0 0 10.1 10.1" xml:space="preserve">
	<polygon fill="#FFFFFF" points="0.9,0 0.9,2.5 5.9,2.5 0,8.4 1.8,10.1 7.6,4.3 7.6,9.2 10.1,9.2 10.1,0 "/>
</svg>
</span></a>
						</div>

						<div class="pricing__menu__tier__detail-toggle">See details+</div>

						<div class="pricing__menu__tier__benefits">
							
								
									<p class="pricing__menu__tier__benefit">
										
											12-month subscription
										
									</p>
								
							
								
									<p class="pricing__menu__tier__benefit">
										
											Unlimited access to all our daily online news and feature stories
										
									</p>
								
							
								
									<p class="pricing__menu__tier__benefit">
										
											6 bi-monthly issues of print + digital magazine
										
									</p>
								
							
								
									<p class="pricing__menu__tier__benefit">
										
											10% discount to MIT Technology Review events
										
									</p>
								
							
								
									<p class="pricing__menu__tier__benefit">
										
											Access to entire PDF magazine archive dating back to 1899
										
									</p>
								
							
								
									<p class="pricing__menu__tier__benefit">
										
											Ad-free website experience
										
									</p>
								
							
								
									<p class="pricing__menu__tier__benefit">
										
											<strong>The Download:</strong> newsletter delivery each weekday to your inbox
										
									</p>
								
							
								
									<p class="pricing__menu__tier__benefit">
										
											The MIT Technology Review App
										
									</p>
								
							
						</div>
					</li>
					
				
					
				
					
				
			</ul>

			<div class="pricing__menu__options">
				<p class="pricing__menu__options__label" data-onload="fadein">
					<span class="asterisk">*</span>
					{! insider.display.footerLabel !}
				</p>
				<p class="pricing__menu__option pricing__menu__option--shipping--us">
					<a href="" data-action="updateShipping" data-shipping="intl" class="pricing__menu__option__link ">See international prices</a>
				</p>
				<p class="pricing__menu__option pricing__menu__option--shipping--intl">
					<a href="" data-action="updateShipping" data-shipping="us" class="pricing__menu__option__link ">See U.S. prices</span></a>
				</p>
				<p class="pricing__menu__option pricing__menu__option--pricing">
					<a href="" data-action="updatePricing" data-pricing="standard" class="pricing__menu__option__link ">Revert to standard pricing</a>
				</p>
			</div>

		</div>

	</div>

</div>

	

	<!-- Slider -->
	
		
<div id="slider" class="l-adunit">
	<div class="adunit ad--slider"
		data-adunit="__site/__slider"
		data-size-mapping="slider"
		data-active="false">
	</div>
	<div id="slider-close">
		<div class="slider-close-icon"></div>
	</div>
</div>

	

	<!-- Article Footer -->
	
<footer class="footer" >
	<div class="footer-width">
		
		<div class="footer__newsletter-bar">
      <div class="footer__newsletter-form">
        <label class="footer__newsletter-bar-text"><strong class="footer__newsletter-bar-text__download">The Download</strong> What&#39;s important in technology and innovation, delivered to you every day</label>
        <script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2.js"></script>
        <script>
          hbspt.forms.create({
            portalId: "4518541",
            formId: "25476bbe-2c35-4451-8f1e-04e0c3ac1898"
          });
        </script>
      </div>
			<div class="footer__social">
				<p class="footer__newsletter-bar-text">Follow us</p>
				<span class="footer__social-icons">
					<a href="https://twitter.com/techreview"><span class="footer__social__text">Twitter</span><i class="footer__social--twitter"></i></a>
					<a href="https://www.facebook.com/technologyreview"><span class="footer__social__text">Facebook</span><i class="footer__social--facebook"></i></a>
					<a href="/rss/"><span class="footer__social__text">RSS</span><i class="footer__social--rss"></i></a>
				</span>
			</div>
		</div>
		
	</div><!-- newsletter bar -->

	<div class="footer__wrapper">
		<div class="footer-width">

			<div class="footer__header">
				<div class="footer__icon"></div>
				<div class="footer__intro">
					<div class="footer__logo-mod">
						<img class="footer__logo" src="https://cdn.technologyreview.com/_/img/horizontal-logo-v2--white.svg" alt="MIT Technology Review">
					</div>
					<p class="footer__intro__text">The mission of MIT Technology Review is to bring about better-informed and more conscious decisions about technology through authoritative, influential, and trustworthy journalism.</p>
				</div>

				<a href="/editions/" class="footer__international-editions">
					<p class="footer__international-editions__text">Browse<br>International<br>Editions</p>
					<span class="footer__international-editions__icon"></span>
				</a>
			</div><!-- footer-main header -->

			<ul class="footer__subnav">
				<li class="footer__subnav__list-title"><span class="footer__subnav__list-title-span">Company</span>
				<ul class="footer__subnav__list">
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/about/">About Us</a></li>
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/careers/">Careers</a></li>
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/media/">Advertise with Us</a></li>
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="https://www.technologyreview.com/s/603603/mit-technology-review-custom-content-showcase/">Insights</a></li>
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/about/licensing-syndication/">Licensing, Syndication, &amp; Reuse</a></li>
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/press-room/">Press Room</a></li>
          <li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="https://go.technologyreview.com/insider/pricing/">Subscriptions</a></li>
				</ul>
				</li>
				<li class="footer__subnav__list-title"><span class="footer__subnav__list-title-span">Your Account</span>
				<ul class="footer__subnav__list">
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/login/" rel="nofollow">Log In / Create Account</a></li>
					
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/activate/" rel="nofollow">Activate Account</a></li>
					
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="https://go.technologyreview.com/newsletters">Newsletters</a></li>
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/account/" rel="nofollow">Manage Account</a></li>
					
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="https://subscribe.technologyreview.com/ecom/mtr/app/live/subcustserv?pagemode=start&org=MTR&publ=TR&php=Y">Manage Subscription</a></li>
					
				</ul>
				</li>
				<li class="footer__subnav__list-title"><span class="footer__subnav__list-title-span">Customer Support</span>
				<ul class="footer__subnav__list">
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/help/">Help/FAQs</a></li>
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/help/contact/">Contact Us</a></li>
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/help/contact/">Feedback</a></li>
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/sitemap/">Sitemap</a></li>
				</ul>
				</li>
				<li class="footer__subnav__list-title"><span class="footer__subnav__list-title-span">More</span>
				<ul class="footer__subnav__list">
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/events/">Events</a></li>
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="http://www.mitef.org">MIT Enterprise Forum</a></li>
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/mit-news/">MIT News</a></li>
				</ul>
				</li>
				<li class="footer__subnav__list-title"><span class="footer__subnav__list-title-span">Policies</span>
				<ul class="footer__subnav__list">
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/about/ethics-statement/">Ethics Statement</a></li>
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/about/terms-of-service/">Terms of Service</a></li>
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/about/privacy/">Privacy</a></li>
          <li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/about/cookies/">Cookie Statement</a></li>
					<li class="footer__subnav__list-item"><a class="footer__subnav__list-item__link" href="/about/commenting-guidelines/">Commenting Guidelines</a></li>
				</ul>
				</li>
			</ul><!-- footer-main-navbar -->

			<p class="footer-copyright">
				<span class="footer-copyright--main"><a href="/about/terms-of-service/">MIT Technology Review &copy; 2019</a></span>
				<span class="footer-version">v.|e<sup>i&pi;</sup>|</span>
			</p>
		</div><!-- footer wrapper -->
	</div>
</footer>


	<!-- Reading Meter -->
	<div class="meter" rv-show="meter.open">
	<div class="meter__numbers">
		<span rv-text="meter.usage"></span>/3</span>
	</div>

	<div class="meter__inner">
		<div class="meter__copy">

			<span rv-show="meter.visible">

				<span rv-show="meter.loggedIn.1">
					<span class="meter__copy__line">
						You've read
						<span rv-text="meter.usageWord"></span> of three
						free articles this month.
						<a class="meter__subscribe__link" href="https://go.technologyreview.com/insider/pricing/">Subscribe now</a> for unlimited online access.
					</span>
				</span>

				<span rv-show="meter.loggedIn.2">
					<span class="visibility--phablet">
						You've read
						<span rv-text="meter.usageWord"></span> of three
						free articles this month.
					</span>
					<span class="meter__copy__line">
						<a class="meter__subscribe__link" href="https://go.technologyreview.com/insider/pricing/">Subscribe now</a> for unlimited online access.
					</span>
				</span>

				<span rv-show="meter.loggedIn.3">
					<span class="visibility--phablet">
						This is your last free article this month.
					</span>
					<span class="meter__copy__line">
						<a class="meter__subscribe__link" href="https://go.technologyreview.com/insider/pricing/">Subscribe now</a> for unlimited online access.
					</span>
				</span>

				<span rv-show="meter.loggedIn.3b">
					<span class="visibility--phablet">
						You've read all your free articles this month.
					</span>
					<span class="meter__copy__line">
						<a class="meter__subscribe__link" href="https://go.technologyreview.com/insider/pricing/">Subscribe now</a> for unlimited online access.
					</span>
				</span>

				<span rv-show="meter.loggedOut.1a">
					<span class="visibility--phablet">
						You've read
						<span rv-text="meter.usageWord"></span> of three
						free articles this month.
					</span>
					<span class="meter__copy__line">
						<a class="meter__subscribe__link" href="/login/?redirectTo=%2Fs%2F613331%2Fthe-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since%2F" rel="nofollow">Log in</a> for more, or <a class="meter__subscribe__link" href="https://go.technologyreview.com/insider/pricing/">subscribe now</a> for unlimited online access.
					</span>
				</span>

				<span rv-show="meter.loggedOut.1b">
					<span class="meter__copy__line">
						<a class="meter__subscribe__link" href="/login/?redirectTo=%2Fs%2F613331%2Fthe-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since%2F" rel="nofollow">Log in</a> for two more free articles, or <a class="meter__subscribe__link" href="https://go.technologyreview.com/insider/pricing/">subscribe now</a>
					</span>
					<span class="visibility--phablet">
						for unlimited online access.
					</span>
				</span>

			</span>
		</div>

		<a class="meter__toggle" onclick="model.meter.open = false"><span class="meter__close"></span></a>
	</div>
</div>


	<!-- Group subscription bar -->
	

	




<script>
serverData = {"userData":{"tier":"","pricing":"","shipping":""},"prices":{"standard":{"print_only":{"us":"$55.95/year","intl":"$65.95/year"},"basic_print":{"us":"$29.95/year","intl":"$39.95/year"},"digital":{"us":"$35.95/year","intl":"$35.95/year"},"print_digital":{"us":"$79.95/year","intl":"$89.95/year"}},"alum":{"print_only":{"us":"Free","intl":"Free"},"basic_print":{"us":"Free","intl":"Free"},"digital":{"us":"Free","intl":"Free"},"print_digital":{"us":"$29.95/year","intl":"$39.95/year"}}},"insiderButtonCampaign":"insider_article_footer","articleData":{},"recaptchaSiteKey":"6Ld7EwoUAAAAAAsArADB7O-2iwPym46rsReGoEZd","url":"https://www.technologyreview.com/s/613331/the-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since/","path":"/s/613331/the-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since/","loginRedirectTo":"/s/613331/the-first-ddos-attack-was-20-years-ago-this-is-what-weve-learned-since/","debug":false,"env":{"label":"prod","rhinoUrl":"https://cms.technologyreview.com","cdnHost":"https://cdn.technologyreview.com","originHost":"https://www.technologyreview.com"},"analytics":{"dataLayer":{"Contributor":"Emerging Technology from the arXiv","PageType":"News","Pubdate":"2019-04-18","WordCount":"01200","DelayPageview":"true","EntryID":613331,"Topic":"Connectivity","ABTestVariant":"topper"},"dfpTargeting":{"page_id":"tr_www_613331","channel":"mobile","topic":"connectivity"}}};
</script>



<script src="https://cdn.technologyreview.com/_/dist/js/default.js?v=bf2fbea2" defer></script>


<!-- AddThis Config -->
<script>
addthis_config = {
	data_track_addressbar: false,
	data_track_clickback: false,
	pubid: 'ra-4df12eda07a410ab',
	ui_use_css : false,
};
addthis_share = {
	passthrough : {
		twitter: {
			text: "The first DDoS attack was 20 years ago. This is what we’ve learned since. - via @techreview",
		}
	},
	url_transforms: {
		add: {
			utm_campaign: 'site_visitor.unpaid.engagement',
			utm_source: '{{code}}',
			utm_medium: 'add_this',
			utm_content: '2019-04-18',
		}
	}
};
</script>

<script type="text/javascript" src="//s7.addthis.com/js/250/addthis_widget.js#async=1" defer></script>


<script src="https://cdn.technologyreview.com/_/dist/js/ArticleSubscriptionStump.js?v=bf2fbea2" defer></script>

<script src="https://cdn.technologyreview.com/_/dist/js/article.js?v=bf2fbea2" defer></script>




<!-- OneTrust Cookies Consent Notice (Production CDN, www.technologyreview.com, en-GB) start -->
<script src="https://cdn.cookielaw.org/consent/a321aa9c-3063-4225-abb6-0285fd5607e6.js" type="text/javascript" charset="UTF-8" defer></script>
<script type="text/javascript">
function OptanonWrapper() { }
</script>
<!-- OneTrust Cookies Consent Notice (Production CDN, www.technologyreview.com, en-GB) end -->


</body>
</html>
